Skip to main content

eFilm 4.0

By November 5, 2015Uncategorized

Sound has officially released eFilm 4.0. Many of your servers will now be loaded with eFilm 4.0 instead of eFilm 3.3. EFilm 3.3 is not compatible with eFilm 4.0 and requires that you install eFilm 4.0 on any clinic computers. For more information, see the eFilm 4.0 installation section.

Leave a Reply